You may have noticed that the legacy HLDSUpdateTool, is deprecated for a while. Since the recent udpate from Steam that forces all CSS clients to use the new SteamPipe system, the server downloaded by HLDSUpdateTool is definitely deprecated.

If you try to run a deprecated version of your server (acquired with HLDSUpdateTool), you will get one of the following :

Your server is out of date.  Please update and restart.

Server will restart on map change.

And the client is getting the following :

The server you are connecting to is running an older version of the game

You can try to update using HLDSUpdateTool but nothing will change, you will be stuck with your old version, and you will keep getting the same errors.

The key is to get the new CSS server software, that uses SteamPipe. To do so, you have to grab the new SteamCMD program, that replaces HLDSUpdateTool, and install the CSS server as explained in Valve documentation.

Here is a few-steps tutorial to install your new CSS server :

  • Make sure you create a new directory for SteamCMD files, do not install it in HLDSUpdateTool directory : mkdir steamcmd && cd steamcmd
  • Download SteamCMD : wget

  • Extract SteamCMD : tar -xzf steamcmd_linux.tar.gz

  • If you are running a 64bit system (every decent server does), install ia32-libs (for instance, in Debian : dpkg --add-architecture i386 && apt-get install ia32-libs).

  • Run SteamCMD : ./ it will update automatically.

  • Install CSS dedicated server, in a custom directory (here it’s the folder css_server in upper directory) :
    ./ +login anonymous +force_install_dir ../css_server/ +app_update 232330 validate +quit

  • Note that the Steam AppID is 232330.
  • Now you can run your new CSS server : get back to the upper directory (cd ..) and start it :
    ./css_server/srcds_run -steam_dir steamcmd/ -steamcmd_script steamcmd/ -console -game cstrike +map de_dust2 -maxplayers 20 -port 27015

Of course, you will have to copy your existing server.cfg, mapcycle, and MODs to your new CSS installation directory (in css_server/cstrike/ sub-folders).


I hope this post will help those who are stuck with these “server deprecated” errors and unable to use their server. Have fun !